Home About Play Contact Wiki Support Chat


If this gets a Post ID of 8192, we advance! (Page 23) / TBG / Text Based Games Forums
Welcome to the TBG Forums!

You are not logged in.

Announcement

For the best site experience: please use the HTTPS versions of the forums. Your browser should display a padlock in the URL if successful.
You may click on "Forums Home" if you are not already on an HTTPS connection.

#551 2021-Jan-17  03:14:41

gilbert_given_TBG
TBGer
From: Stickland
Registered: 2020-Nov-30
Posts: 8,328
Website

Re: If this gets a Post ID of 8192, we advance!

Here's what I got so far:

comment="該程序使用文言转换編譯。"
码="杰"
輸入="嗨,您好!"
码表=[]
储存空间=16
存储=[]
for (計數=0;計數<储存空间;計數++){
    存储.push(0);
}
方向=1;comment="零:右,一:下,二:左,三:上"
水平的位置=0 // xpos 
垂直的位置=0 // ypos
計數=0
寬度=0 // width
高度=0 // height
码表[水平的位置]=[]
for (甲=0;甲<码.length;甲++){
    if (码[甲]=="\n"){
        if (寬度<計數){
            寬度=計數
        }
        水平的位置++
        高度++
        码表[水平的位置]=[]
        水平的位置=0 
        計數=0
    } else {
        码表[水平的位置][垂直的位置]=码[甲]
        計數++
        水平的位置++
    }
}
for (甲=0;甲<寬度;甲++){
    for (乙=0;乙<高度;乙++){
        測試=码表[水平的位置][垂直的位置]+[]
        if(測試.length==9){
            码表[水平的位置][垂直的位置]=" "
        }
    }
}
水平的位置=0
垂直的位置=0
玩=true
comment="找到英雄:他應該在第一線。"
function 找到英雄(){
    for (甲=0;甲<寬度;甲++){
        測試=码表[0][甲]
        if(測試=="杰"){
            垂直的位置=甲
            码表[0][甲]=" "
            return
        }
        console.log("找不到杰,請確保他在第一個車道上。");
        玩=false
    }
}
輸入清單=[]
if (玩){
    for (計數=0;計數<輸入.length;計數++){
        輸入清單.push(輸入[計數]);
    }
    function 獲得狀態(水平,垂直){
        return 码表[水平][垂直]
    }
    function 向上滑動(水平,垂直){
        上下=0
        左右=0
        找=""
        最少=0
        最多=高度
        comment="尋找隧道洞"
        for (甲=0;甲<寬度;甲++){
            找=码表[甲][垂直]
            if(找=="階"){
                if(甲<垂直){
                    if(最少+1<甲){
                        最少=甲
                    }
                } else {
                    if(最多>甲){
                        最多=甲
                    }
                }
            }
        }
        comment="移動它"
        臨時=码表[最少][垂直]
        for (甲=垂直;甲<最多-2;甲++){
            码表[甲][垂直]=码表[甲+1][垂直]
        }
        码表[最多-1][垂直]=臨時
    }
}

And here's the compiled program:

吾有一術。名之曰「賦值」
欲行是術。必先得一物。曰「對象」。一物。曰「域」。一物。曰「值」。
乃行是術曰。
    乃得  對象[域] = 值;
是謂「賦值」之術也。

吾有一術。名之曰「獲取」
欲行是術。必先得一物。曰「對象」。一物。曰「域」。
乃行是術曰。
    乃得  對象[域]
是謂「獲取」之術也。

批曰。「「============」」
昔之「comment」者。今「「該程序使用文言转换編譯。」」是矣。
昔之「码」者。今「「杰」」是矣。
昔之「輸入」者。今「「嗨,您好!」」是矣。
吾有一列。名之曰「癸十」
昔之「码表」者。今「癸十」是矣。
昔之「储存空间」者。今一十六是矣。
吾有一列。名之曰「子庚」
昔之「存储」者。今「子庚」是矣。
昔之「計數」者。今零是矣。
恆為是。
    吾有一爻。名之曰「辰二」。若「計數」小於「储存空间」者。昔之「辰二」者。今陽是矣云云。
    若「辰二」等於零者。
        乃止。
    云云。
    充「存储」以零。
    加「計數」以一。
    昔之「計數」者。今其是矣。
云云。
昔之「方向」者。今一是矣。
昔之「comment」者。今「「零:右,一:下,二:左,三:上」」是矣。
昔之「水平的位置」者。今零是矣。
昔之「垂直的位置」者。今零是矣。
昔之「計數」者。今零是矣。
昔之「寬度」者。今零是矣。
昔之「高度」者。今零是矣。
吾有一列。名之曰「辰十」
施「賦值」於「码表」。於「水平的位置」。於「辰十」。
噫。昔之「甲」者。今零是矣。
恆為是。
    夫「码」之長。    吾有一爻。名之曰「申亥」。若「甲」小於其者。昔之「申亥」者。今陽是矣云云。
    若「申亥」等於零者。
        乃止。
    云云。
    施「獲取」於「码」。於「甲」。
    名之曰「亥辰」。
    若「亥辰」等於「「
」」者。
        若「寬度」小於「計數」者。
            昔之「寬度」者。今「計數」是矣。
        云云。
        加「水平的位置」以一。
        昔之「水平的位置」者。今其是矣。
        加「高度」以一。
        昔之「高度」者。今其是矣。
        吾有一列。名之曰「地丙」
        施「賦值」於「码表」。於「水平的位置」。於「地丙」。
噫。        昔之「水平的位置」者。今零是矣。
        昔之「計數」者。今零是矣。
    若非。
        施「獲取」於「码表」。於「水平的位置」。
        名之曰「乙酉」。
        施「獲取」於「码表」。於「水平的位置」。
        名之曰「子午」。
        施「獲取」於「码」。於「甲」。
        名之曰「酉子」。
        施「賦值」於「子午」。於「垂直的位置」。於「酉子」。
噫。        加「計數」以一。
        昔之「計數」者。今其是矣。
        加「水平的位置」以一。
        昔之「水平的位置」者。今其是矣。
    云云。
    加「甲」以一。
    昔之「甲」者。今其是矣。
云云。
昔之「甲」者。今零是矣。
恆為是。
    吾有一爻。名之曰「二申」。若「甲」小於「寬度」者。昔之「二申」者。今陽是矣云云。
    若「二申」等於零者。
        乃止。
    云云。
    昔之「乙」者。今零是矣。
    恆為是。
        吾有一爻。名之曰「十子」。若「乙」小於「高度」者。昔之「十子」者。今陽是矣云云。
        若「十子」等於零者。
            乃止。
        云云。
        施「獲取」於「码表」。於「水平的位置」。
        名之曰「戊庚」。
        施「獲取」於「码表」。於「水平的位置」。
        名之曰「地申」。
        施「獲取」於「地申」。於「垂直的位置」。
        名之曰「丙地」。
        吾有一列。名之曰「丙卯」
        加「丙地」以「丙卯」。
        昔之「測試」者。今其是矣。
        若「測試」之長等於九者。
            施「獲取」於「码表」。於「水平的位置」。
            名之曰「二巳」。
            施「獲取」於「码表」。於「水平的位置」。
            名之曰「癸己」。
            施「賦值」於「癸己」。於「垂直的位置」。於「「 」」。
噫。        云云。
        加「乙」以一。
        昔之「乙」者。今其是矣。
    云云。
    加「甲」以一。
    昔之「甲」者。今其是矣。
云云。
昔之「水平的位置」者。今零是矣。
昔之「垂直的位置」者。今零是矣。
昔之「玩」者。今陽是矣。
昔之「comment」者。今「「找到英雄:他應該在第一線。」」是矣。
吾有一術。名之曰「找到英雄」
欲行是術。必先得
乃行是術曰。
    昔之「甲」者。今零是矣。
    恆為是。
        吾有一爻。名之曰「己未」。若「甲」小於「寬度」者。昔之「己未」者。今陽是矣云云。
        若「己未」等於零者。
            乃止。
        云云。
        夫「码表」之一。
        名之曰「辰未」。
        夫「码表」之一。
        名之曰「未午」。
        施「獲取」於「未午」。於「甲」。
        昔之「測試」者。今其是矣。
        若「測試」等於「「杰」」者。
            昔之「垂直的位置」者。今「甲」是矣。
            夫「码表」之一。
            名之曰「丁癸」。
            夫「码表」之一。
            名之曰「己地」。
            施「賦值」於「己地」。於「甲」。於「「 」」。
噫。            乃得 undefined
        云云。
        吾有一言。曰「「找不到杰,請確保他在第一個車道上。」」。
        書之。
        昔之「玩」者。今陰是矣。
        加「甲」以一。
        昔之「甲」者。今其是矣。
    云云。
是謂「找到英雄」之術也。

噫。吾有一列。名之曰「十庚」
昔之「輸入清單」者。今「十庚」是矣。
若「玩」者。
    昔之「計數」者。今零是矣。
    恆為是。
        夫「輸入」之長。        吾有一爻。名之曰「亥酉」。若「計數」小於其者。昔之「亥酉」者。今陽是矣云云。
        若「亥酉」等於零者。
            乃止。
        云云。
        施「獲取」於「輸入」。於「計數」。
        名之曰「亥酉四」。
        充「輸入清單」以「亥酉四」。
        加「計數」以一。
        昔之「計數」者。今其是矣。
    云云。
    吾有一術。名之曰「獲得狀態」
    欲行是術。必先得    一物。曰「水平」。一物。曰「垂直」。
    乃行是術曰。
        施「獲取」於「码表」。於「水平」。
        名之曰「庚地」。
        施「獲取」於「码表」。於「水平」。
        名之曰「二地」。
        施「獲取」於「二地」。於「垂直」。
        名之曰「壬卯」。
        乃得 「壬卯」
    是謂「獲得狀態」之術也。

噫。    吾有一術。名之曰「向上滑動」
    欲行是術。必先得    一物。曰「水平」。一物。曰「垂直」。
    乃行是術曰。
        昔之「上下」者。今零是矣。
        昔之「左右」者。今零是矣。
        昔之「找」者。今「「」」是矣。
        昔之「最少」者。今零是矣。
        昔之「最多」者。今「高度」是矣。
        昔之「comment」者。今「「尋找隧道洞」」是矣。
        昔之「甲」者。今零是矣。
        恆為是。
            吾有一爻。名之曰「庚戌」。若「甲」小於「寬度」者。昔之「庚戌」者。今陽是矣云云。
            若「庚戌」等於零者。
                乃止。
            云云。
            施「獲取」於「码表」。於「甲」。
            名之曰「壬甲」。
            施「獲取」於「码表」。於「甲」。
            名之曰「癸壬」。
            施「獲取」於「癸壬」。於「垂直」。
            昔之「找」者。今其是矣。
            若「找」等於「「階」」者。
                若「甲」小於「垂直」者。
                    加「最少」以一。
                    名之曰「丁卯」。
                    若「丁卯」小於「甲」者。
                        昔之「最少」者。今「甲」是矣。
                    云云。
                若非。
                    若「最多」大於「甲」者。
                        昔之「最多」者。今「甲」是矣。
                    云云。
                云云。
            云云。
            加「甲」以一。
            昔之「甲」者。今其是矣。
        云云。
        昔之「comment」者。今「「移動它」」是矣。
        施「獲取」於「码表」。於「最少」。
        名之曰「庚午」。
        施「獲取」於「码表」。於「最少」。
        名之曰「未未」。
        施「獲取」於「未未」。於「垂直」。
        昔之「臨時」者。今其是矣。
        昔之「甲」者。今「垂直」是矣。
        恆為是。
            減「最多」以二。
            吾有一爻。名之曰「辰辰」。若「甲」小於其者。昔之「辰辰」者。今陽是矣云云。
            若「辰辰」等於零者。
                乃止。
            云云。
            施「獲取」於「码表」。於「甲」。
            名之曰「未戌」。
            施「獲取」於「码表」。於「甲」。
            名之曰「辰戌」。
            加「甲」以一。
            名之曰「申丑」。
            施「獲取」於「码表」。於「申丑」。
            名之曰「丁丙」。
            加「甲」以一。
            名之曰「丁支」。
            施「獲取」於「码表」。於「丁支」。
            名之曰「午戊」。
            施「獲取」於「午戊」。於「垂直」。
            名之曰「午癸」。
            施「賦值」於「辰戌」。於「垂直」。於「午癸」。
噫。            加「甲」以一。
            昔之「甲」者。今其是矣。
        云云。
        夫「码表」之「最多」。
        名之曰「辛戊」。
        夫「码表」之「最多」。
        名之曰「酉丁」。
        施「賦值」於「酉丁」。於「垂直」。於「臨時」。
噫。    是謂「向上滑動」之術也。

噫。云云。

Nice, I'm KOTP once again.

Last edited by gilbert_given_TBG (2021-Jan-17  03:15:12)


I got the banana. I have acquired potassium.
(siggy too thick, scrolling is needed for #TeamScratchStyle)
Some of my esolangs I made: redirected here
Stuff I made: Smiley Code Decoder Word Shuffler List nBASIC PseudoSmiley Pybolge Unshrekton OLLY in Wenyan ESC JSC TPSC Programmable Text Generator Why? Flerovium HTML to BBcode Another BMP codec Unicode Adventures
Links: My sig editor DWiki esolangs.org TIO Scratch alt Ocular
Lists: BMP codecs Nonsense programs Gilbert's Random and Pointless Topics
Key: j1ZCdkFA99
*search up "Prototype Autonomous Management Agent".

Offline

#552 2021-Jan-17  11:20:21

Byron_Inc_TBG
TBGer
From: Duolingo
Registered: 2020-Jul-29
Posts: 27,138
Website

Re: If this gets a Post ID of 8192, we advance!

Wow


Somehow I'm the TBGer with the most posts.
I'm not the friendliest person in the world.
I removed my images.

Offline

#553 2021-Jan-17  15:23:18

gilbert_given_TBG
TBGer
From: Stickland
Registered: 2020-Nov-30
Posts: 8,328
Website

Re: If this gets a Post ID of 8192, we advance!

Turns out Wenyan doesn't support direct assignment to arrays (you know like array[1]=3), unless if you use JS code. So, I have to scrap my plan of removing all non-CJK characters. hmm


I got the banana. I have acquired potassium.
(siggy too thick, scrolling is needed for #TeamScratchStyle)
Some of my esolangs I made: redirected here
Stuff I made: Smiley Code Decoder Word Shuffler List nBASIC PseudoSmiley Pybolge Unshrekton OLLY in Wenyan ESC JSC TPSC Programmable Text Generator Why? Flerovium HTML to BBcode Another BMP codec Unicode Adventures
Links: My sig editor DWiki esolangs.org TIO Scratch alt Ocular
Lists: BMP codecs Nonsense programs Gilbert's Random and Pointless Topics
Key: j1ZCdkFA99
*search up "Prototype Autonomous Management Agent".

Offline

#554 2021-Jan-17  15:27:56

Byron_Inc_TBG
TBGer
From: Duolingo
Registered: 2020-Jul-29
Posts: 27,138
Website

Re: If this gets a Post ID of 8192, we advance!

Hm


Somehow I'm the TBGer with the most posts.
I'm not the friendliest person in the world.
I removed my images.

Offline

#555 2021-Jan-17  15:51:20

gilbert_given_TBG
TBGer
From: Stickland
Registered: 2020-Nov-30
Posts: 8,328
Website

Re: If this gets a Post ID of 8192, we advance!

I'm scouring the issues of wenyan-lang in github and I find a topic that shows it got featured in a social media platform I don't know. I won't share the image, since part of it is inappropriate.


I got the banana. I have acquired potassium.
(siggy too thick, scrolling is needed for #TeamScratchStyle)
Some of my esolangs I made: redirected here
Stuff I made: Smiley Code Decoder Word Shuffler List nBASIC PseudoSmiley Pybolge Unshrekton OLLY in Wenyan ESC JSC TPSC Programmable Text Generator Why? Flerovium HTML to BBcode Another BMP codec Unicode Adventures
Links: My sig editor DWiki esolangs.org TIO Scratch alt Ocular
Lists: BMP codecs Nonsense programs Gilbert's Random and Pointless Topics
Key: j1ZCdkFA99
*search up "Prototype Autonomous Management Agent".

Offline

#556 2021-Jan-17  16:06:40

PkmnQ
TBGer
From: A very complicated powerpoint
Registered: 2020-Mar-15
Posts: 11,776
Website

Re: If this gets a Post ID of 8192, we advance!

Another baba is you level: HXFN-7HYR

Last edited by PkmnQ (2021-Jan-17  16:58:43)

Offline

#557 2021-Jan-17  16:26:42

gilbert_given_TBG
TBGer
From: Stickland
Registered: 2020-Nov-30
Posts: 8,328
Website

Re: If this gets a Post ID of 8192, we advance!

unfortunately, i don't have baba is you.


I got the banana. I have acquired potassium.
(siggy too thick, scrolling is needed for #TeamScratchStyle)
Some of my esolangs I made: redirected here
Stuff I made: Smiley Code Decoder Word Shuffler List nBASIC PseudoSmiley Pybolge Unshrekton OLLY in Wenyan ESC JSC TPSC Programmable Text Generator Why? Flerovium HTML to BBcode Another BMP codec Unicode Adventures
Links: My sig editor DWiki esolangs.org TIO Scratch alt Ocular
Lists: BMP codecs Nonsense programs Gilbert's Random and Pointless Topics
Key: j1ZCdkFA99
*search up "Prototype Autonomous Management Agent".

Offline

#558 2021-Jan-17  16:31:53

PkmnQ
TBGer
From: A very complicated powerpoint
Registered: 2020-Mar-15
Posts: 11,776
Website

Re: If this gets a Post ID of 8192, we advance!

Don't worry just the editor (which you can also play custom levels on) is free, and here it is.

Offline

#559 2021-Jan-17  16:33:53

gilbert_given_TBG
TBGer
From: Stickland
Registered: 2020-Nov-30
Posts: 8,328
Website

Re: If this gets a Post ID of 8192, we advance!

Oh boy my wenyan script have 13 pages...


I got the banana. I have acquired potassium.
(siggy too thick, scrolling is needed for #TeamScratchStyle)
Some of my esolangs I made: redirected here
Stuff I made: Smiley Code Decoder Word Shuffler List nBASIC PseudoSmiley Pybolge Unshrekton OLLY in Wenyan ESC JSC TPSC Programmable Text Generator Why? Flerovium HTML to BBcode Another BMP codec Unicode Adventures
Links: My sig editor DWiki esolangs.org TIO Scratch alt Ocular
Lists: BMP codecs Nonsense programs Gilbert's Random and Pointless Topics
Key: j1ZCdkFA99
*search up "Prototype Autonomous Management Agent".

Offline

#560 2021-Jan-17  20:25:30

gilbert_given_TBG
TBGer
From: Stickland
Registered: 2020-Nov-30
Posts: 8,328
Website

Re: If this gets a Post ID of 8192, we advance!

I have done it: OLLY in Wenyan!
Books (with stamps of approval wink )

c04e6b.png
2d21.png
2.png
3.png
4.png
5.png
6.png
7.png
8.png

Source code:
comment="該程序使用文言转换編譯。"
码=`杰
東南
溜東聽說躍溜勝
`
輸入=[1,2,3,4,5]
輸入指標=0
码表=[]
储存空间=16
存儲位置=0
存储=[]
for (計數=0;計數<储存空间;計數++){
    存储.push(0);
}
方向=1;comment="零:右,一:下,二:左,三:上"
水平的位置=0 // xpos 
垂直的位置=0 // ypos
計數=0
寬度=0 // width
高度=0 // height
码表[水平的位置]=[]
for (甲=0;甲<码.length;甲++){
    if (码[甲]=="\n"){
        if (寬度<計數){
            寬度=計數
        }
        水平的位置++
        高度++
        码表[水平的位置]=[]
        垂直的位置=0 
        計數=0
    } else {
        码表[水平的位置][垂直的位置]=码[甲]
        計數++
        垂直的位置++
    }
}
console.log(寬度)
for (甲=0;甲<高度;甲++){
    for (乙=0;乙<寬度;乙++){
	try{
        測試=码表[甲][乙]+[]
        if(測試.length==9){
            码表[甲][乙]=" "
        }
	}catch(e){
	码表[甲][乙]=" "
	}
    }
}
console.log(码表)
水平的位置=0
垂直的位置=0
玩=true
comment="找到英雄:他應該在第一線。"
function 找到英雄(){
    for (甲=0;甲<寬度;甲++){
        測試=码表[0][甲]
        if(測試=="杰"){
            垂直的位置=甲
            码表[0][甲]=" "
            return
        }
        console.log("找不到杰,請確保他在第一個車道上。");
        玩=false
    }
}
輸入清單=[]
if (玩){
    for (計數=0;計數<輸入.length;計數++){
        輸入清單.push(輸入[計數]);
    }
    function 獲得狀態(水平,垂直){
        return 码表[水平][垂直]
    }
    function 向上滑動(水平,垂直){
        上下=0
        左右=0
        找=""
        最少=0
        最多=高度
        comment="尋找隧道洞"
        for (甲=0;甲<高度;甲++){
            找=码表[甲][垂直]
            if(找=="階"){
                if(甲<垂直){
                    if(最少+1<甲){
                        最少=甲
                    }
                } else {
                    if(最多>甲){
                        最多=甲
                    }
                }
            }
        }
        comment="移動它"
        臨時=码表[最少][垂直]
        for (甲=垂直;甲<最多-2;甲++){
            码表[甲][垂直]=码表[甲+1][垂直]
        }
        码表[最多-1][垂直]=臨時
    }
    stage="2"
    function 向下滑動(水平,垂直){
        上下=0
        左右=0
        找=""
        最少=0
        最多=高度
        comment="尋找隧道洞"
        for (甲=0;甲<高度;甲++){
            找=码表[甲][垂直]
            if(找=="階"){
                if(甲<垂直){
                    if(最少+1<甲){
                        最少=甲
                    }
                } else {
                    if(最多>甲){
                        最多=甲
                    }
                }
            }
        }
        comment="移動它"
        臨時=码表[最多-1][垂直]
        for (甲=0;甲<最多-2-垂直;甲++){
            码表[最多-1-甲][垂直]=码表[最多-2-甲][垂直]
        }
        码表[最少][垂直]=臨時
    }
    function 向右滑動(水平,垂直){
        上下=0
        左右=0
        找=""
        最少=0
        最多=寬度
        comment="尋找隧道洞"
        for (甲=0;甲<寬度;甲++){
            找=码表[水平][甲]
            if(找=="溜"){
                if(甲<水平){
                    if(最少+1<甲){
                        最少=甲
                    }
                } else {
                    if(最多>甲){
                        最多=甲
                    }
                }
            }
        }
        comment="移動它"
        臨時=码表[水平][垂直]
        for (甲=垂直;甲<最多-2;甲++){
            码表[水平][甲]=码表[水平][甲+1]
        }
        码表[水平][最多-1]=臨時
    }
    function 向左滑動(水平,垂直){
        上下=0
        左右=0
        找=""
        最少=0
        最多=寬度
        comment="尋找隧道洞"
        for (甲=0;甲<寬度;甲++){
            找=码表[水平][甲]
            if(找=="溜"){
                if(甲<水平){
                    if(最少+1<甲){
                        最少=甲
                    }
                } else {
                    if(最多>甲){
                        最多=甲
                    }
                }
            }
        }
        comment="移動它"
        臨時=码表[水平][最多-1]
        for (甲=0;甲<最多-2-垂直;甲++){
            码表[水平][最多-1-甲]=码表[水平][最多-2-甲]
        }
        码表[水平][垂直]=臨時
    }
    stage="3"
    function 移動英雄(){
        if(方向==0){
            垂直的位置++
        } else if(方向==1){
            水平的位置++
        } else if(方向==2){
            垂直的位置--
        } else if(方向==3){
            水平的位置--
        }
        水平的位置=水平的位置%高度
        垂直的位置=垂直的位置%寬度
        if(水平的位置<0){
            水平的位置=0
        }
        if(垂直的位置<0){
            垂直的位置=0
        }
    }
    戰=true
    while (戰){
	console.log("Paper Mario is in ("+水平的位置+", "+垂直的位置+"), going to direction "+方向+", cell pointer "+存儲位置)
        地點=獲得狀態(水平的位置,垂直的位置)
        if(地點=="東"){
            方向=0
        } else if(地點=="南"){
            方向=1
        } else if(地點=="西"){
            方向=2
        } else if(地點=="北"){
            方向=3
        } else if(地點=="溜"){
            if(方向==0||方向==2){
                方向+=2
                方向=方向%4
                移動英雄()
                while(獲得狀態(水平的位置,垂直的位置)!="溜"){
                    移動英雄()
                }
                方向+=2
                方向=方向%4
            }
        } else if(地點=="階"){
            if(方向==1||方向==3){
                方向+=2
                方向=方向%4
                移動英雄()
                while(獲得狀態(水平的位置,垂直的位置)!="階"){
                    移動英雄()
                }
                方向+=2
                方向=方向%4
            }
        } else if(地點=="勝"){
            戰=false
        } else if(地點=="躍"){
            if(存储[存儲位置]==0){
                移動英雄()
            }
        } else if(地點=="上"){
            向上滑動(水平的位置,垂直的位置)
        } else if(地點=="下"){
            向下滑動(水平的位置,垂直的位置)
        } else if(地點=="左"){
            向左滑動(水平的位置,垂直的位置)
        } else if(地點=="右"){
            向右滑動(水平的位置,垂直的位置)
        } else if(地點=="加"){
            存储[存儲位置]+=0
        } else if(地點=="減"){
            存储[存儲位置]-=0
        } else if(地點=="明"){
            存儲位置+=0
        } else if(地點=="前"){
            存儲位置-=0
        } else if(地點=="說"){
            console.log(存储[存儲位置])
        } else if(地點=="聽"){
            測試=輸入[輸入指標]+[]
	    存储[存儲位置]=0
            if(測試.length!=9){
                存储[存儲位置]=輸入[輸入指標]
            }
            輸入指標++
        }
        移動英雄()
    } 
}
Complied code:
批曰。「「該程序使用文言轉換器 。我不會在這裡發表文言評論。」」。
吾有一術。名之曰「賦值」
欲行是術。必先得一物。曰「對象」。一物。曰「域」。一物。曰「值」。
乃行是術曰。
    乃得  對象[域] = 值;
是謂「賦值」之術也。

吾有一術。名之曰「獲取」
欲行是術。必先得一物。曰「對象」。一物。曰「域」。
乃行是術曰。
    乃得  對象[域]
是謂「獲取」之術也。
昔之「码」者。今「「杰
東南
溜東聽說躍溜勝
」」是矣。
吾有一列。名之曰「輸入」
充「輸入」以一。以二。以三。以四。以五。
有數零。名之曰「輸入指標」
有數零。名之曰「存儲位置 」
吾有一列。名之曰「癸十」
昔之「码表」者。今「癸十」是矣。
昔之「储存空间」者。今一十六是矣。
吾有一列。名之曰「子庚」
昔之「存储」者。今「子庚」是矣。
昔之「計數」者。今零是矣。
恆為是。
    吾有一爻。名之曰「辰二」。若「計數」小於「储存空间」者。昔之「辰二」者。今陽是矣云云。
    若「辰二」等於零者。
        乃止。
    云云。
    充「存储」以零。
    加「計數」以一。
    昔之「計數」者。今其是矣。
云云。
昔之「方向」者。今一是矣。批曰。「「零:右一:下二:左三:上」」
昔之「水平的位置」者。今零是矣。
昔之「垂直的位置」者。今零是矣。
昔之「計數」者。今零是矣。
昔之「寬度」者。今零是矣。
昔之「高度」者。今零是矣。
吾有一列。名之曰「辰十」
施「賦值」於「码表」。於「水平的位置」。於「辰十」。
噫。昔之「甲」者。今零是矣。
恆為是。
    夫「码」之長。    吾有一爻。名之曰「申亥」。若「甲」小於其者。昔之「申亥」者。今陽是矣云云。
    若「申亥」等於零者。
        乃止。
    云云。
    施「獲取」於「码」。於「甲」。
    名之曰「亥辰」。
    若「亥辰」等於「「
」」者。
        若「寬度」小於「計數」者。
            昔之「寬度」者。今「計數」是矣。
        云云。
        加「水平的位置」以一。
        昔之「水平的位置」者。今其是矣。
        加「高度」以一。
        昔之「高度」者。今其是矣。
        吾有一列。名之曰「地丙」
        施「賦值」於「码表」。於「水平的位置」。於「地丙」。
噫。        昔之「垂直的位置」者。今零是矣。
        昔之「計數」者。今零是矣。
    若非。
        施「獲取」於「码表」。於「水平的位置」。
        名之曰「乙酉」。
        施「獲取」於「码表」。於「水平的位置」。
        名之曰「子午」。
        施「獲取」於「码」。於「甲」。
        名之曰「酉子」。
        施「賦值」於「子午」。於「垂直的位置」。於「酉子」。
噫。        加「計數」以一。
        昔之「計數」者。今其是矣。
        加「垂直的位置」以一。
        昔之「垂直的位置」者。今其是矣。
    云云。
    加「甲」以一。
    昔之「甲」者。今其是矣。
云云。
昔之「甲」者。今零是矣。
恆為是。
    吾有一爻。名之曰「二申」。若「甲」小於「高度」者。昔之「二申」者。今陽是矣云云。
    若「二申」等於零者。
        乃止。
    云云。
    昔之「乙」者。今零是矣。
    恆為是。
        吾有一爻。名之曰「十子」。若「乙」小於「寬度」者。昔之「十子」者。今陽是矣云云。
        若「十子」等於零者。
            乃止。
        云云。姑妄行此。
        施「獲取」於「码表」。於「甲」。
        名之曰「戊庚」。
        施「獲取」於「码表」。於「甲」。
        名之曰「地申」。
        施「獲取」於「地申」。於「乙」。
        名之曰「丙地」。
        吾有一列。名之曰「丙卯」
        加「丙地」以「丙卯」。
        昔之「測試」者。今其是矣。
        若「測試」之長等於九者。
            施「獲取」於「码表」。於「甲」。
            名之曰「二巳」。
            施「獲取」於「码表」。於「甲」。
            名之曰「癸己」。
            施「賦值」於「癸己」。於「乙」。於「「 」」。
噫。        云云。如事不諧。
				施「賦值」於「癸己」。於「乙」。於「「 」」。乃作罷。
        加「乙」以一。
        昔之「乙」者。今其是矣。
    云云。
    加「甲」以一。
    昔之「甲」者。今其是矣。
云云。
昔之「水平的位置」者。今零是矣。
昔之「垂直的位置」者。今零是矣。
昔之「玩」者。今陽是矣。
批曰。「「找到英雄:他應該在第一線。」」
吾有一術。名之曰「找到英雄」
欲行是術。必先得
乃行是術曰。
    昔之「甲」者。今零是矣。
    恆為是。
        吾有一爻。名之曰「己未」。若「甲」小於「寬度」者。昔之「己未」者。今陽是矣云云。
        若「己未」等於零者。
            乃止。
        云云。
        夫「码表」之一。
        名之曰「辰未」。
        夫「码表」之一。
        名之曰「未午」。
        施「獲取」於「未午」。於「甲」。
        昔之「測試」者。今其是矣。
        若「測試」等於「「杰」」者。
            昔之「垂直的位置」者。今「甲」是矣。
            夫「码表」之一。
            名之曰「丁癸」。
            夫「码表」之一。
            名之曰「己地」。
            施「賦值」於「己地」。於「甲」。於「「 」」。
噫。            乃得 一
        云云。
        吾有一言。曰「「找不到杰,請確保他在第一個車道上。」」。
        書之。
        昔之「玩」者。今陰是矣。
        加「甲」以一。
        昔之「甲」者。今其是矣。
    云云。
是謂「找到英雄」之術也。

噫。吾有一列。名之曰「十庚」
昔之「輸入清單」者。今「十庚」是矣。
若「玩」者。
    吾有一術。名之曰「獲得狀態」
    欲行是術。必先得    一物。曰「水平」。一物。曰「垂直」。
    乃行是術曰。
        施「獲取」於「码表」。於「水平」。
        名之曰「庚地」。
        施「獲取」於「码表」。於「水平」。
        名之曰「二地」。
        施「獲取」於「二地」。於「垂直」。
        名之曰「壬卯」。
        乃得 「壬卯」
    是謂「獲得狀態」之術也。

噫。    吾有一術。名之曰「向上滑動」
    欲行是術。必先得    一物。曰「水平」。一物。曰「垂直」。
    乃行是術曰。
        昔之「上下」者。今零是矣。
        昔之「左右」者。今零是矣。
        昔之「找」者。今「「」」是矣。
        昔之「最少」者。今零是矣。
        昔之「最多」者。今「高度」是矣。
        者。今「「尋找隧道洞」」
        昔之「甲」者。今零是矣。
        恆為是。
            吾有一爻。名之曰「庚戌」。若「甲」小於「寬度」者。昔之「庚戌」者。今陽是矣云云。
            若「庚戌」等於零者。
                乃止。
            云云。
            施「獲取」於「码表」。於「甲」。
            名之曰「壬甲」。
            施「獲取」於「码表」。於「甲」。
            名之曰「癸壬」。
            施「獲取」於「癸壬」。於「垂直」。
            昔之「找」者。今其是矣。
            若「找」等於「「階」」者。
                若「甲」小於「垂直」者。
                    加「最少」以一。
                    名之曰「丁卯」。
                    若「丁卯」小於「甲」者。
                        昔之「最少」者。今「甲」是矣。
                    云云。
                若非。
                    若「最多」大於「甲」者。
                        昔之「最多」者。今「甲」是矣。
                    云云。
                云云。
            云云。
            加「甲」以一。
            昔之「甲」者。今其是矣。
        云云。
        批曰。「「移動它」」
        施「獲取」於「码表」。於「最少」。
        名之曰「庚午」。
        施「獲取」於「码表」。於「最少」。
        名之曰「未未」。
        施「獲取」於「未未」。於「垂直」。
        昔之「臨時」者。今其是矣。
        昔之「甲」者。今「垂直」是矣。
        恆為是。
            減「最多」以二。
            吾有一爻。名之曰「辰辰」。若「甲」小於其者。昔之「辰辰」者。今陽是矣云云。
            若「辰辰」等於零者。
                乃止。
            云云。
            施「獲取」於「码表」。於「甲」。
            名之曰「未戌」。
            施「獲取」於「码表」。於「甲」。
            名之曰「辰戌」。
            加「甲」以一。
            名之曰「申丑」。
            施「獲取」於「码表」。於「申丑」。
            名之曰「丁丙」。
            加「甲」以一。
            名之曰「丁支」。
            施「獲取」於「码表」。於「丁支」。
            名之曰「午戊」。
            施「獲取」於「午戊」。於「垂直」。
            名之曰「午癸」。
            施「賦值」於「辰戌」。於「垂直」。於「午癸」。
噫。            加「甲」以一。
            昔之「甲」者。今其是矣。
        云云。
        夫「码表」之「最多」。
        名之曰「辛戊」。
        夫「码表」之「最多」。
        名之曰「酉丁」。
        施「賦值」於「酉丁」。於「垂直」。於「臨時」。
噫。    是謂「向上滑動」之術也。

噫。吾有一術。名之曰「向下滑動」
    欲行是術。必先得    一物。曰「水平」。一物。曰「垂直」。
    乃行是術曰。
        昔之「上下」者。今零是矣。
        昔之「左右」者。今零是矣。
        昔之「找」者。今「「」」是矣。
        昔之「最少」者。今零是矣。
        昔之「最多」者。今「高度」是矣。
        批曰。「「尋找隧道洞」」
        昔之「甲」者。今零是矣。
        恆為是。
            吾有一爻。名之曰「戊辛」。若「甲」小於「高度」者。昔之「戊辛」者。今陽是矣云云。
            若「戊辛」等於零者。
                乃止。
            云云。
            施「獲取」於「码表」。於「甲」。
            名之曰「壬地」。
            施「獲取」於「码表」。於「甲」。
            名之曰「辰庚」。
            施「獲取」於「辰庚」。於「垂直」。
            昔之「找」者。今其是矣。
            若「找」等於「「階」」者。
                若「甲」小於「垂直」者。
                    加「最少」以一。
                    名之曰「亥支」。
                    若「亥支」小於「甲」者。
                        昔之「最少」者。今「甲」是矣。
                    云云。
                若非。
                    若「最多」大於「甲」者。
                        昔之「最多」者。今「甲」是矣。
                    云云。
                云云。
            云云。
            加「甲」以一。
            昔之「甲」者。今其是矣。
        云云。
        批曰。「「移動它」」
        夫「码表」之「最多」。
        名之曰「辛丙」。
        夫「码表」之「最多」。
        名之曰「十寅」。
        施「獲取」於「十寅」。於「垂直」。
        昔之「臨時」者。今其是矣。
        昔之「甲」者。今零是矣。
        恆為是。
            減「最多」以二。
            名之曰「支己」。
            減「支己」以「垂直」。
            吾有一爻。名之曰「甲酉」。若「甲」小於其者。昔之「甲酉」者。今陽是矣云云。
            若「甲酉」等於零者。
                乃止。
            云云。
            減「最多」以一。
            名之曰「未丙」。
            減「未丙」以「甲」。
            名之曰「戊申」。
            施「獲取」於「码表」。於「戊申」。
            名之曰「亥辛」。
            減「最多」以一。
            名之曰「丑乙」。
            減「丑乙」以「甲」。
            名之曰「寅戌」。
            施「獲取」於「码表」。於「寅戌」。
            名之曰「辰丁」。
            減「最多」以二。
            名之曰「己甲」。
            減「己甲」以「甲」。
            名之曰「卯癸一」。
            施「獲取」於「码表」。於「卯癸一」。
            名之曰「丙二」。
            減「最多」以二。
            名之曰「辰戌」。
            減「辰戌」以「甲」。
            名之曰「戊辰」。
            施「獲取」於「码表」。於「戊辰」。
            名之曰「辛辛」。
            施「獲取」於「辛辛」。於「垂直」。
            名之曰「十丑」。
            施「賦值」於「辰丁」。於「垂直」。於「十丑」。
噫。            加「甲」以一。
            昔之「甲」者。今其是矣。
        云云。
        施「獲取」於「码表」。於「最少」。
        名之曰「丁丑」。
        施「獲取」於「码表」。於「最少」。
        名之曰「壬寅」。
        施「賦值」於「壬寅」。於「垂直」。於「臨時」。
噫。    是謂「向下滑動」之術也。

噫。    吾有一術。名之曰「向右滑動」
    欲行是術。必先得    一物。曰「水平」。一物。曰「垂直」。
    乃行是術曰。
        昔之「上下」者。今零是矣。
        昔之「左右」者。今零是矣。
        昔之「找」者。今「「」」是矣。
        昔之「最少」者。今零是矣。
        昔之「最多」者。今「寬度」是矣。
        批曰。「「尋找隧道洞」」
        昔之「甲」者。今零是矣。
        恆為是。
            吾有一爻。名之曰「庚辰」。若「甲」小於「寬度」者。昔之「庚辰」者。今陽是矣云云。
            若「庚辰」等於零者。
                乃止。
            云云。
            施「獲取」於「码表」。於「水平」。
            名之曰「甲戊」。
            施「獲取」於「码表」。於「水平」。
            名之曰「酉子」。
            施「獲取」於「酉子」。於「甲」。
            昔之「找」者。今其是矣。
            若「找」等於「「階」」者。
                若「甲」小於「水平」者。
                    加「最少」以一。
                    名之曰「甲乙」。
                    若「甲乙」小於「甲」者。
                        昔之「最少」者。今「甲」是矣。
                    云云。
                若非。
                    若「最多」大於「甲」者。
                        昔之「最多」者。今「甲」是矣。
                    云云。
                云云。
            云云。
            加「甲」以一。
            昔之「甲」者。今其是矣。
        云云。
        批曰。「「移動它」」
        施「獲取」於「码表」。於「水平」。
        名之曰「地丑」。
        施「獲取」於「码表」。於「水平」。
        名之曰「午癸」。
        施「獲取」於「午癸」。於「垂直」。
        昔之「臨時」者。今其是矣。
        昔之「甲」者。今「垂直」是矣。
        恆為是。
            減「最多」以二。
            吾有一爻。名之曰「甲卯」。若「甲」小於其者。昔之「甲卯」者。今陽是矣云云。
            若「甲卯」等於零者。
                乃止。
            云云。
            施「獲取」於「码表」。於「水平」。
            名之曰「子戊八」。
            施「獲取」於「码表」。於「水平」。
            名之曰「亥丑」。
            施「獲取」於「码表」。於「水平」。
            名之曰「癸戌」。
            加「甲」以一。
            名之曰「辰癸」。
            施「獲取」於「癸戌」。於「辰癸」。
            名之曰「辰二」。
            施「賦值」於「亥丑」。於「甲」。於「辰二」。
噫。            加「甲」以一。
            昔之「甲」者。今其是矣。
        云云。
        施「獲取」於「码表」。於「水平」。
        名之曰「卯己」。
        昔之「卯己」之「最多」者。今「臨時」是矣。
    是謂「向右滑動」之術也。

噫。    吾有一術。名之曰「向左滑動」
    欲行是術。必先得    一物。曰「水平」。一物。曰「垂直」。
    乃行是術曰。
        昔之「上下」者。今零是矣。
        昔之「左右」者。今零是矣。
        昔之「找」者。今「「」」是矣。
        昔之「最少」者。今零是矣。
        昔之「最多」者。今「寬度」是矣。
        批曰。「「尋找隧道洞」」
        昔之「甲」者。今零是矣。
        恆為是。
            吾有一爻。名之曰「支支」。若「甲」小於「寬度」者。昔之「支支」者。今陽是矣云云。
            若「支支」等於零者。
                乃止。
            云云。
            施「獲取」於「码表」。於「水平」。
            名之曰「丁亥」。
            施「獲取」於「码表」。於「水平」。
            名之曰「十辛」。
            施「獲取」於「十辛」。於「甲」。
            昔之「找」者。今其是矣。
            若「找」等於「「階」」者。
                若「甲」小於「水平」者。
                    加「最少」以一。
                    名之曰「未丙一」。
                    若「未丙一」小於「甲」者。
                        昔之「最少」者。今「甲」是矣。
                    云云。
                若非。
                    若「最多」大於「甲」者。
                        昔之「最多」者。今「甲」是矣。
                    云云。
                云云。
            云云。
            加「甲」以一。
            昔之「甲」者。今其是矣。
        云云。
        批曰。「「移動它」」
        施「獲取」於「码表」。於「水平」。
        名之曰「亥丙」。
        夫「亥丙」之「最多」。
        昔之「臨時」者。今其是矣。
        昔之「甲」者。今零是矣。
        恆為是。
            減「最多」以二。
            名之曰「支癸」。
            減「支癸」以「垂直」。
            吾有一爻。名之曰「乙癸零」。若「甲」小於其者。昔之「乙癸零」者。今陽是矣云云。
            若「乙癸零」等於零者。
                乃止。
            云云。
            施「獲取」於「码表」。於「水平」。
            名之曰「二午」。
            施「獲取」於「码表」。於「水平」。
            名之曰「甲癸」。
            減「最多」以一。
            名之曰「乙子」。
            減「乙子」以「甲」。
            名之曰「地地」。
            施「獲取」於「码表」。於「水平」。
            名之曰「巳未」。
            減「最多」以二。
            名之曰「丑戌」。
            減「丑戌」以「甲」。
            名之曰「甲寅」。
            施「獲取」於「巳未」。於「甲寅」。
            名之曰「丁丑三」。
            施「賦值」於「甲癸」。於「地地」。於「丁丑三」。
噫。            加「甲」以一。
            昔之「甲」者。今其是矣。
        云云。
        施「獲取」於「码表」。於「水平」。
        名之曰「壬亥」。
        施「獲取」於「码表」。於「水平」。
        名之曰「未甲」。
        施「賦值」於「未甲」。於「垂直」。於「臨時」。
噫。    是謂「向左滑動」之術也。

噫。    吾有一術。名之曰「移動英雄」
    欲行是術。必先得    
    乃行是術曰。
        若「方向」等於零者。
            加「垂直的位置」以一。
            昔之「垂直的位置」者。今其是矣。
        若非。
            若「方向」等於一者。
                加「水平的位置」以一。
                昔之「水平的位置」者。今其是矣。
            若非。
                若「方向」等於二者。
                    減「垂直的位置」以一。
                    昔之「垂直的位置」者。今其是矣。
                若非。
                    若「方向」等於三者。
                        減「水平的位置」以一。
                        昔之「水平的位置」者。今其是矣。
                    云云。
                云云。
            云云。
        云云。
        除「水平的位置」以「高度」。所餘幾何。
        昔之「水平的位置」者。今其是矣。
        除「垂直的位置」以「寬度」。所餘幾何。
        昔之「垂直的位置」者。今其是矣。
        若「水平的位置」小於零者。
            昔之「水平的位置」者。今零是矣。
        云云。
        若「垂直的位置」小於零者。
            昔之「垂直的位置」者。今零是矣。
        云云。
    是謂「移動英雄」之術也。

噫。    昔之「戰」者。今陽是矣。
    恆為是。
        若「戰」等於零者。
            乃止。
        云云。
        施「獲得狀態」於「水平的位置」。於「垂直的位置」。
        昔之「地點」者。今其是矣。
        若「地點」等於「「東」」者。
            昔之「方向」者。今零是矣。
        若非。
            若「地點」等於「「南」」者。
                昔之「方向」者。今一是矣。
            若非。
                若「地點」等於「「西」」者。
                    昔之「方向」者。今二是矣。
                若非。
                    若「地點」等於「「北」」者。
                        昔之「方向」者。今三是矣。
                    若非。
                        若「地點」等於「「溜」」者。
                            吾有一爻。名之曰「癸未」。若「方向」等於零者。昔之「癸未」者。今陽是矣云云。
                            吾有一爻。名之曰「巳十一」。若「方向」等於二者。昔之「巳十一」者。今陽是矣云云。
                            夫「癸未」「巳十一」中有陽乎。
                            名之曰「辛支」。
                            若「辛支」者。
                                加「方向」以二。
                                昔之「方向」者。今其是矣。
                                除「方向」以四。所餘幾何。
                                昔之「方向」者。今其是矣。
                                施「移動英雄」
                                恆為是。
                                    施「獲得狀態」於「水平的位置」。於「垂直的位置」。
                                    名之曰「亥十」。
                                    吾有一爻。名之曰「巳寅」。若「亥十」不等於「「溜」」者。昔之「巳寅」者。今陽是矣云云。
                                    若「巳寅」等於零者。
                                        乃止。
                                    云云。
                                    施「移動英雄」
                                云云。
                                加「方向」以二。
                                昔之「方向」者。今其是矣。
                                除「方向」以四。所餘幾何。
                                昔之「方向」者。今其是矣。
                            云云。
                        若非。
                            若「地點」等於「「階」」者。
                                吾有一爻。名之曰「午戊」。若「方向」等於一者。昔之「午戊」者。今陽是矣云云。
                                吾有一爻。名之曰「酉午」。若「方向」等於三者。昔之「酉午」者。今陽是矣云云。
                                夫「午戊」「酉午」中有陽乎。
                                名之曰「巳丙」。
                                若「巳丙」者。
                                    加「方向」以二。
                                    昔之「方向」者。今其是矣。
                                    除「方向」以四。所餘幾何。
                                    昔之「方向」者。今其是矣。
                                    施「移動英雄」
                                    恆為是。
                                        施「獲得狀態」於「水平的位置」。於「垂直的位置」。
                                        名之曰「地申」。
                                        吾有一爻。名之曰「乙二二」。若「地申」不等於「「階」」者。昔之「乙二二」者。今陽是矣云云。
                                        若「乙二二」等於零者。
                                            乃止。
                                        云云。
                                        施「移動英雄」
                                    云云。
                                    加「方向」以二。
                                    昔之「方向」者。今其是矣。
                                    除「方向」以四。所餘幾何。
                                    昔之「方向」者。今其是矣。
                                云云。
                            若非。
                                若「地點」等於「「勝」」者。
                                    昔之「戰」者。今陰是矣。
                                若非。
                                    若「地點」等於「「躍」」者。
                                        施「獲取」於「存储」。於「存儲位置」。
                                        名之曰「午庚」。
                                        若「午庚」等於零者。
                                            施「移動英雄」
                                        云云。
                                    若非。
                                        若「地點」等於「「上」」者。
                                            施「向上滑動」於「水平的位置」。於「垂直的位置」。
                                        若非。
                                            若「地點」等於「「下」」者。
                                                施「向下滑動」於「水平的位置」。於「垂直的位置」。
                                            若非。
                                                若「地點」等於「「左」」者。
                                                    施「向左滑動」於「水平的位置」。於「垂直的位置」。
                                                若非。
                                                    若「地點」等於「「右」」者。
                                                        施「向右滑動」於「水平的位置」。於「垂直的位置」。
                                                    若非。
                                                        若「地點」等於「「加」」者。
                                                            施「獲取」於「存储」。於「存儲位置」。
                                                            名之曰「午酉八」。
                                                            加「午酉八」以零。
                                                            名之曰「子戌」。
                                                            施「賦值」於「存储」。於「存儲位置」。於「子戌」。
噫。                                                        若非。
                                                            若「地點」等於「「減」」者。
                                                                施「獲取」於「存储」。於「存儲位置」。
                                                                名之曰「癸辛」。
                                                                減「癸辛」以零。
                                                                名之曰「庚十」。
                                                                施「賦值」於「存储」。於「存儲位置」。於「庚十」。
噫。                                                            若非。
                                                                若「地點」等於「「明」」者。
                                                                    加「存儲位置」以零。
                                                                    昔之「存儲位置」者。今其是矣。
                                                                若非。
                                                                    若「地點」等於「「前」」者。
                                                                        減「存儲位置」以零。
                                                                        昔之「存儲位置」者。今其是矣。
                                                                    若非。
                                                                        若「地點」等於「「說」」者。
                                                                            施「獲取」於「存储」。於「存儲位置」。
                                                                            名之曰「丙乙」。
                                                                            吾有一物。曰「丙乙」。
                                                                            書之。
                                                                        若非。
                                                                            若「地點」等於「「聽」」者。
                                                                                施「獲取」於「輸入」。於「輸入指標」。
                                                                                名之曰「午庚一」。
                                                                                吾有一列。名之曰「辛丑」
                                                                                加「午庚一」以「辛丑」。
                                                                                昔之「測試」者。今其是矣。
                                                                                施「賦值」於「存储」。於「存儲位置」。於零。
噫。                                                                                若「測試」之長不等於九者。
                                                                                    施「獲取」於「輸入」。於「輸入指標」。
                                                                                    名之曰「十酉」。
                                                                                    施「賦值」於「存储」。於「存儲位置」。於「十酉」。
噫。                                                                                云云。
                                                                                加「輸入指標」以一。
                                                                                昔之「輸入指標」者。今其是矣。
                                                                            云云。
                                                                        云云。
                                                                    云云。
                                                                云云。
                                                            云云。
                                                        云云。
                                                    云云。
                                                云云。
                                            云云。
                                        云云。
                                    云云。
                                云云。
                            云云。
                        云云。
                    云云。
                云云。
            云云。
        云云。
        施「移動英雄」云云
云云。
Translation of the instruction:

中国哦李
An esoteric programming language, about a hero in war.

Example:

東南
溜東聽說躍溜勝

The hero will repeat what he hears.

Instructions:
北南西東   : Direction for the hero to go
上下左右   : Direction for the hero to slide the lane (The hero will not be affected)
溜階   : Gates (for the moving cells and the hero)
杰   : The hero (initial direction is always down)
躍   : Make the hero jump for 2 lanes if memory in pointer is zero
勝   : Declare victory

The hero will triumph if he got the 勝 opcode.

Items:
加   : Increment memory at pointer
減   : Decrement memory at pointer
明   : Move pointer left
前   : Move pointer right
說   : Say number at pointer
聽   : Hear number to pointer

Any other characters will be ignored.

Gates are NOT teleporters, if cells and the hero are going to a gate that is perpendicular with the direction of movement, it will be ignored.
For example:


東隙階隙勝
東西階東西

On this, the war will finish.

杰隙東西
溜隙溜
勝隙東西

The same applies.

杰階
隙溜
東下西勝溜

隙溜
隙階

You get the idea by now.

Note that the hero can also wrap around the edges.

For example:

西隙隙隙南加加
隙隙隙隙勝

Even when he's wrapping in 溜 or 階.

For example:

南隙溜隙勝

The hero should be stuck.


I got the banana. I have acquired potassium.
(siggy too thick, scrolling is needed for #TeamScratchStyle)
Some of my esolangs I made: redirected here
Stuff I made: Smiley Code Decoder Word Shuffler List nBASIC PseudoSmiley Pybolge Unshrekton OLLY in Wenyan ESC JSC TPSC Programmable Text Generator Why? Flerovium HTML to BBcode Another BMP codec Unicode Adventures
Links: My sig editor DWiki esolangs.org TIO Scratch alt Ocular
Lists: BMP codecs Nonsense programs Gilbert's Random and Pointless Topics
Key: j1ZCdkFA99
*search up "Prototype Autonomous Management Agent".

Offline

#561 2021-Jan-17  20:55:08

PkmnQ
TBGer
From: A very complicated powerpoint
Registered: 2020-Mar-15
Posts: 11,776
Website

Re: If this gets a Post ID of 8192, we advance!

I found a glitch in Baba is You. LQQ3-AUQR

Offline

#562 2021-Jan-17  22:31:20

gilbert_given_TBG
TBGer
From: Stickland
Registered: 2020-Nov-30
Posts: 8,328
Website

Re: If this gets a Post ID of 8192, we advance!

I might revisit my Appel + NEAT project to make it an initial-random NEAT instead of non-speciated NEAT. Also, because I think it's completely unnecessary, I installed BiYLEβ.


I got the banana. I have acquired potassium.
(siggy too thick, scrolling is needed for #TeamScratchStyle)
Some of my esolangs I made: redirected here
Stuff I made: Smiley Code Decoder Word Shuffler List nBASIC PseudoSmiley Pybolge Unshrekton OLLY in Wenyan ESC JSC TPSC Programmable Text Generator Why? Flerovium HTML to BBcode Another BMP codec Unicode Adventures
Links: My sig editor DWiki esolangs.org TIO Scratch alt Ocular
Lists: BMP codecs Nonsense programs Gilbert's Random and Pointless Topics
Key: j1ZCdkFA99
*search up "Prototype Autonomous Management Agent".

Offline

#563 2021-Jan-17  23:58:00

Byron_Inc_TBG
TBGer
From: Duolingo
Registered: 2020-Jul-29
Posts: 27,138
Website

Re: If this gets a Post ID of 8192, we advance!

.


Somehow I'm the TBGer with the most posts.
I'm not the friendliest person in the world.
I removed my images.

Offline

#564 2021-Jan-18  00:00:40

PkmnQ
TBGer
From: A very complicated powerpoint
Registered: 2020-Mar-15
Posts: 11,776
Website

Re: If this gets a Post ID of 8192, we advance!

I found a 3 character username on scratch that wasn't taken. It is taken now.

Offline

#565 2021-Jan-18  01:59:40

7vv
New TBGer
Registered: 2021-Jan-18
Posts: 1

Re: If this gets a Post ID of 8192, we advance!

This is the username.


tr3

Offline

#566 2021-Jan-18  02:00:39

PkmnQ
TBGer
From: A very complicated powerpoint
Registered: 2020-Mar-15
Posts: 11,776
Website

Re: If this gets a Post ID of 8192, we advance!

Will confirm. The username is 7vv.

Offline

#567 2021-Jan-18  08:29:18

realicraft
TBGer
From: reali's cubicle, sknn hq
Registered: 2018-Jun-25
Posts: 2,948
Website

Re: If this gets a Post ID of 8192, we advance!

neutral


so how's your day been
___                                               
videos | Fighting Simulator 3: Subtitle | Calendar | Universe Manager 2
16384 progress: ~56.03% @ 135d (0y 4m 13d) [10/19/2021] {9180/16384}
ProgBar02.pngProgBar00.pngProgBar00.pngProgBar00.pngProgBar00.pngProgBar18.pngProgBar29.pngProgBar01.pngProgBar01.pngProgBar01.pngProgBar01.pngProgBar05.pngProgBar07.png
ProgBar02.pngProgBar00.pngProgBar00.pngProgBar00.pngProgBar00.pngProgBar08.pngProgBar40.pngProgBar01.pngProgBar01.pngProgBar01.pngProgBar01.pngProgBar05.pngProgBar06.png
ProgBar03.pngProgBar01.pngProgBar01.pngProgBar01.pngProgBar01.pngProgBar51.pngProgBar29.pngProgBar01.pngProgBar01.pngProgBar01.pngProgBar01.pngProgBar49.png
47007.pngtongueneutralyikes

Offline

#568 2021-Jan-18  11:24:37

Byron_Inc_TBG
TBGer
From: Duolingo
Registered: 2020-Jul-29
Posts: 27,138
Website

Re: If this gets a Post ID of 8192, we advance!

Ooh


Somehow I'm the TBGer with the most posts.
I'm not the friendliest person in the world.
I removed my images.

Offline

#569 2021-Jan-18  12:13:45

BusyBeaver565
TBGer
From: Utopia
Registered: 2021-Jan-03
Posts: 111

Re: If this gets a Post ID of 8192, we advance!

569


Busy Bionic Beaver | Computer | Googology | Diagonals
TonyBrown148 | BronyTown187 | BlueKirin208 | KurtBach325 | BusyBeaver565
Logo-ubuntu_no%28r%29-black_orange-hex.svg

Offline

#570 2021-Jan-18  14:41:27

Byron_Inc_TBG
TBGer
From: Duolingo
Registered: 2020-Jul-29
Posts: 27,138
Website

Re: If this gets a Post ID of 8192, we advance!

570


Somehow I'm the TBGer with the most posts.
I'm not the friendliest person in the world.
I removed my images.

Offline

#571 2021-Jan-18  15:08:54

BusyBeaver565
TBGer
From: Utopia
Registered: 2021-Jan-03
Posts: 111

Re: If this gets a Post ID of 8192, we advance!

77777777777777777777


Busy Bionic Beaver | Computer | Googology | Diagonals
TonyBrown148 | BronyTown187 | BlueKirin208 | KurtBach325 | BusyBeaver565
Logo-ubuntu_no%28r%29-black_orange-hex.svg

Offline

#572 2021-Jan-18  15:15:26

Byron_Inc_TBG
TBGer
From: Duolingo
Registered: 2020-Jul-29
Posts: 27,138
Website

Re: If this gets a Post ID of 8192, we advance!

572


Somehow I'm the TBGer with the most posts.
I'm not the friendliest person in the world.
I removed my images.

Offline

#573 2021-Jan-18  15:26:07

BusyBeaver565
TBGer
From: Utopia
Registered: 2021-Jan-03
Posts: 111

Re: If this gets a Post ID of 8192, we advance!

l


Busy Bionic Beaver | Computer | Googology | Diagonals
TonyBrown148 | BronyTown187 | BlueKirin208 | KurtBach325 | BusyBeaver565
Logo-ubuntu_no%28r%29-black_orange-hex.svg

Offline

#574 2021-Jan-18  15:37:30

Byron_Inc_TBG
TBGer
From: Duolingo
Registered: 2020-Jul-29
Posts: 27,138
Website

Re: If this gets a Post ID of 8192, we advance!

574


Somehow I'm the TBGer with the most posts.
I'm not the friendliest person in the world.
I removed my images.

Offline

#575 2021-Jan-18  15:59:08

KurtBach325
TBGer
From: Utopia
Registered: 2020-Dec-23
Posts: 102

Re: If this gets a Post ID of 8192, we advance!

https://lipsum.com/



Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nam dolor nisi, interdum hendrerit dui quis, blandit posuere dui. Nunc nec tellus urna. Maecenas at lobortis lacus. Donec id felis ipsum. Proin in eros metus. Donec bibendum turpis eu luctus aliquam. Nulla venenatis sem est. Integer eu luctus quam. Donec magna nibh, aliquet eget accumsan id, commodo non leo. Cras sit amet volutpat nibh. Donec posuere, elit nec venenatis scelerisque, nisi arcu iaculis ex, nec semper libero erat vitae urna. Duis non lectus purus. Proin risus dui, dictum a scelerisque sed, condimentum eu dui. Curabitur porta pulvinar velit, id porttitor mauris posuere et. Fusce vel ultricies sapien. Vestibulum iaculis feugiat massa et malesuada.

Nam ac tincidunt ligula, in tempus dolor. Donec at efficitur lacus, nec dictum risus. Pellentesque vitae mauris maximus, malesuada ante quis, consequat dui. Donec porttitor neque viverra odio fermentum, non dignissim mauris gravida. Morbi in justo mauris. Sed et iaculis elit. Maecenas nisl ligula, luctus at commodo laoreet, venenatis ornare elit. Suspendisse potenti. Proin porta pulvinar auctor. Vivamus ligula ex, mattis quis mi in, malesuada mattis elit. Aliquam venenatis porttitor neque, at tempor libero rhoncus non. Proin orci sem, ullamcorper quis nisl ac, elementum pellentesque orci. Donec vel odio vitae dolor feugiat facilisis id ut nulla. Morbi laoreet mattis magna, sed bibendum elit ultricies cursus. Duis ornare tincidunt tempus.

Vestibulum accumsan est in porttitor condimentum. Mauris vulputate arcu quis sapien efficitur accumsan. Duis lobortis augue non est convallis molestie. Integer posuere pulvinar suscipit. Cras sollicitudin sapien id elementum bibendum. Vivamus vitae vehicula nibh. Curabitur blandit mi at nunc pretium tincidunt. Sed commodo porta enim, id viverra nulla efficitur eu. Pellentesque nec hendrerit turpis. Proin ullamcorper, nisl rhoncus convallis molestie, dolor turpis auctor lacus, vitae tincidunt orci quam pretium odio. Sed tristique malesuada euismod. Maecenas tincidunt ac quam vitae euismod. Vivamus rhoncus sapien vel orci auctor, id vulputate mauris viverra. Proin ipsum leo, mollis nec euismod vitae, ornare eu nunc. Sed a iaculis neque. Pellentesque ut lectus dolor.

Curabitur ultricies orci ligula, sit amet facilisis purus iaculis eu. In scelerisque, mauris tristique auctor vulputate, nunc urna sollicitudin turpis, vel rhoncus nisi arcu sit amet mi. Quisque eget nunc a sapien commodo euismod sed in quam. Praesent faucibus neque massa, eu ullamcorper felis feugiat ut. Ut vehicula lectus nunc, a commodo tellus imperdiet in. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Vestibulum non sollicitudin quam. Nunc volutpat, libero sit amet eleifend lobortis, enim lorem vestibulum elit, quis maximus eros sapien sed lectus. Donec dapibus semper augue non semper.

Vestibulum arcu justo, scelerisque id maximus vel, condimentum a felis. Nulla nunc odio, tincidunt sed est sit amet, pulvinar venenatis lacus. Ut semper pulvinar sagittis. Pellentesque vel dolor mauris. Donec ac eros malesuada, sagittis magna quis, bibendum tellus. Aliquam ut egestas urna. Quisque commodo libero quis sem scelerisque, in suscipit est auctor. Curabitur nec tincidunt eros. Quisque eu lorem finibus, tincidunt ligula id, egestas velit. Mauris vel magna sollicitudin, blandit nisi at, sollicitudin nulla.


Kurt Cornelis Bach | Incompleteness | Impossible objects | Fugues and Ricercars
TonyBrown148 | BronyTown187 | BlueKirin208 | KurtBach325 | BusyBeaver565
Godel%2C_Escher%2C_Bach_%28first_edition%29.jpg

Offline

Board footer

Powered by FluxBB